A critical path traversal flaw in Kyverno 1.16.0 through 1.19.1 lets a tenant who can create a NamespacedValidatingPolicy read and write any object in the cluster, which can lead to full cluster takeover.
What Is It
CVE-2026-122311 is a path traversal weakness (CWE-22) in Kyverno, the Kubernetes policy engine. Kyverno does not validate path segments in the resource argument of the CEL functions resource.get() and resource.post(). That allows namespaced CEL policies to reach outside their own namespace.
A tenant allowed to create a NamespacedValidatingPolicy can insert .. segments into the resource path. The resulting requests run under the admission controller's ServiceAccount. This lets the tenant read and write arbitrary cluster objects, not just objects in their own namespace.
Why It Matters
Namespace scoping is what keeps tenants apart in a multi-tenant cluster. This flaw breaks that boundary. A tenant with limited rights gets the privileges of Kyverno's admission controller ServiceAccount, and NVD's description says this leads to cluster takeover.
Scoring from the CNA (VulnCheck):
- CVSS 3.1: 9.9 CRITICAL (
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H). The attack works over the network, has low complexity, needs only low privileges and no user interaction, and its impact crosses the namespace boundary (Scope: Changed). - CVSS 4.0: 9.4 CRITICAL, with high impact on confidentiality, integrity and availability for both the vulnerable system and other systems.
Exploitation status: The CISA KEV entry supplied for this CVE was empty, so KEV does not confirm active exploitation. The CVSS 4.0 exploit maturity field is "Not Defined." NVD lists the record as "Awaiting Analysis."
What's Vulnerable
- Product: Kyverno (
pkg:golang/github.com/kyverno/kyverno) - Affected: versions 1.16.0 up to but not including 1.19.2
- Unaffected: 1.19.2 and later
- Exposure condition: clusters where tenants can create NamespacedValidatingPolicy resources
Patch Status
The vendor data lists Kyverno 1.19.2 as unaffected. Administrators running 1.16.0 through 1.19.1 should upgrade to 1.19.2 or later. Until then, review which tenants can create NamespacedValidatingPolicy resources, since that is the access needed to exploit the flaw. CISA has not set a KEV required action or due date because no KEV entry was supplied. See the GitHub and VulnCheck advisories below for vendor guidance.