A critical authorization bypass in Kyverno 1.17.0 through 1.19.1 lets a namespace tenant use the privileged background controller to overwrite Secrets, Deployments, or policies in other namespaces.
What Is It
CVE-2026-122303 is a missing-authorization flaw (CWE-862) in Kyverno, the Kubernetes policy engine. It sits in the mutate-existing feature of NamespacedMutatingPolicy, in the targetMatchConstraints.expression field. An attacker can write a CEL expression that returns a map literal describing a fake target with any metadata.namespace they choose. Kyverno's privileged background controller then mutates that target, even though it lives outside the attacker's own namespace.
VulnCheck disclosed the issue, and NVD published it on 2026-11-05. The NVD record is still marked "Awaiting Analysis."
Why It Matters
Kyverno often enforces tenant isolation in multi-tenant clusters. This bug breaks that isolation. A user who can create policies only in their own namespace can use the controller's higher privileges to change resources anywhere in the cluster. The description names Secrets, Deployments, and policies as possible targets.
Scores:
- CVSS 3.1: 9.9 Critical (
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H). The attack works over the network, needs low complexity and only low privileges, and requires no user interaction. The scope is changed, and confidentiality, integrity, and availability impacts are all high. - CVSS 4.0: 9.4 Critical. Both the vulnerable system and subsequent systems have high impact.
Exploitation status: No CISA KEV entry was supplied for this CVE, so active exploitation is not confirmed in this data. The CVSS 4.0 exploit maturity field is "Not Defined."
What's Vulnerable
- Product: Kyverno (
pkg:golang/github.com/kyverno/kyverno) - Affected: versions 1.17.0 up to, but not including, 1.19.2
- Not affected: version 1.19.2
Exposure applies to clusters running an affected version where tenants are allowed to create NamespacedMutatingPolicy resources.
Patch Status
The issue is fixed in Kyverno 1.19.2. Organizations running 1.17.0 through 1.19.1 should upgrade to 1.19.2 or later. There is no CISA required action or due date, because the CVE is not in KEV. For maintainer guidance, see the GitHub security advisory below.